На каждом следующем дне рождения Винни Пух съедает столько же меда, что и на двух предыдущих. На двух первых днях рождения у Пяточка и у Кролика он съел по 100 г меда. Написать программу, определяющую, сколько килограммов меда съест Винни Пух на -ом дне рождения.
Формат входных данных
Во входном файле задано единственное число (1 до 40).
Формат выходных данных
Выведите, сколько килограммов меда съест Винни Пух на этот день рождения с точностью до одного знака после десятичной точки.
Var
n,a,b,c,c2,i:integer;
Begin
Write(Введите число );
Readln(n);
a:=100;
b:=100;
for i:= 1 to n do Begin
c:=a+b; a:=b; b:=c;
End;
c2:=c div 1000;
write(c2,.);
c:=c div 100 mod 10;
write(c, кг съел Винни);
End.
Оцени ответ
