составить программу,которая определяет сколько раз встречается в таблице а максимальное по величине число.Pascal.Массивы.Помогите,пожалуйста
const n=100;
m=100;
var A: array[1..n,1..m] of integer;
i,j,maxi,maxj,k: integer;
begin
randomize;
for i := 1 to n do begin
for j := 1 to m do begin
A[i,j] := random(100);
end;
end;
maxi := 1;
maxj := 1;
for i := 1 to n do begin
for j := 1 to m do begin
if (A[i,j] > A[maxi,maxj]) then begin
maxi := i;
maxj := j;
end;
end;
end;
k := 0;
for i := 1 to n do begin
for j := 1 to m do begin
if (A[i,j] == A[maxi,maxj]) then k := k + 1;
end;
end;
writeln(k = , k);
end.
Оцени ответ
