Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен удвоенному числу, введенному с клавиатуры;
2-й — равен квадрату суммы индексов предыдущего элемента;
3-й — равен остатку от деления индекса текущего элемента на 2.

Сделал задачу по условию, которое понял.
var 
a: array[1..3, 1..6] of integer; 
i, j: integer;
begin 
Writeln(Введите 6 чисел через Enter ); 
for i := 1 to 3 do   
for j := 1 to 6 do     
case j of       
1, 4: begin Readln(a[i, j]);a[i, j] := 2 * a[i, j]; end;       
2, 5: a[i, j] := sqr(i + j - 1);       
3, 6: a[i, j] := j mod 2;     
End; 
Writeln(Сформированный массив );      
for i := 1 to 3 do   begin   
for j := 1 to 6 do     
write(a[i, j], );   
Writeln;
end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку