Нужно написать программу на PascalABC
Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 4. Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число-сумму чисел, оканчивающихся на 4.
Пример работы программы:
Входные данные: 3 14 25 24
Выходные данные 38

Var n,k,s:integer;
begin
  writeln(Сколько чисел в последовательности?);
  readln(n);
  for var i:=1 to n do begin
    k:=random(1,30000);
    write(k:6);
    if k mod 10 = 4 then s:=s+k;
    if i mod 10 = 0 then writeln;
  end; 
  writeln();
  writeln(Сумма чисел, заканчивающихся на 4: ,s);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку