Баба-Яга увлекается изобретением новых заклинаний для заданий Ивану Царевичу. В этот раз она придумала заклинание:3 6 9 6 9 12 9 12 15 12 15 18 15 18 21... Чтобы снять заклинание Ивану царевичу необходимо произнести число, которое будет стоять на 2015 месте?Составьте программу и помогите Ивану Царевичу решить задачу
{В данной последовательности к числу сначала 2 раза прибавляется 3, после один раз вычитается 3. Данная программа "ест" много памяти, но с ходу я ничего лучше не могу придумать}
//Pascal ABC.NET v3.0 сборка 1111
Var
i,k:integer;
ar:array[1..2100] of integer;
begin
ar[1]:=3;
ar[2]:=6;
ar[3]:=9;
ar[4]:=6;
i:=4;
while i<2015 do
begin;
inc(i);
ar[i]:=ar[i-1]+3;
inc(i);
ar[i]:=ar[i-1]+3;
inc(i);
ar[i]:=ar[i-1]-3;
end;
write(ar[2015]);
end.
Ответ: 2019
Оцени ответ
