Помогите написать программу на паскале абс
Файловый тип данных.
задача: Дан целочисленный файл А. Записать в файл В все положительные числа.
// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
var f,fp: file of integer;
var i:integer;
Assign(f,in.int); Reset(f);
Assign(fp,out.int); Rewrite(fp);
while not eof(f) do begin
Read(f,i);
if i>0 then Write(fp,i)
end;
Close(f); Close(fp)
end.
Прикрепленный файл in.txt - тестовый in.int, у которого переименовано расширение, поскольку файл с расширением int присоединить сюда не получается.
Оцени ответ
