Найти среднее время,затрачиваемое на выполнение домашнего задания учениками.В классе 24 человека,затрчаиваемое время случайно в диапазоне от 3 до 76 минут.
На языке Паскаль составить программу
//PascalABC.NET 3.0
begin
var a := ArrRandom(24, 3, 76);
writeln(Затрачиваемое учениками время: );
a.Println;
writeln(Среднее время: , a.Average : 0 : 2);
end.
//FPC / Turbo Pascal
var
a, i, sum: integer;
begin
writeln(Затрачиваемое учениками время: );
for i := 1 to 24 do
begin
a := random(74) + 3;
sum := sum + a;
write(a, );
end;
writeln;
writeln(Среднее время: , sum / 24 : 0 : 2);
end.
Оцени ответ
