Даны 3 действительных числа. возвести в квадрат те из них, значение которых неотрицательно, а в четвертую степень отрицательные числа. составить программу на языке Паскаль, которая выводит на экран
ответ для введенных с клавиатуры чисел. Протестировать с числами 5,2,1. Решить с помощью условного оператора. Очень срочно. даю 30 баллов!
Var
a,b,c:real;
begin
read(a,b,c);
writeln;
if a>=0 then writeln(sqr(a)) else writeln(power(a,4));
if b>=0 then writeln(sqr(b)) else writeln(power(b,4));
if c>=0 then writeln(sqr(c)) else writeln(power(c,4));
end.
Оцени ответ
