Напишите программу, которая вводит натуральное число N и выводит на экран чётные положительные степени числа 2, не большие, чем N , в порядке убывания.

Var n,k,m: integer;
begin
  write(число:  );  readln(n);
  m:=1;
  k:=trunc(log2(n));
  if (k mod 2)=1 then   m:=m shl (k-1)
  else m:=m shl k;
  repeat
    write(m, );
    m:=m shr 2;
  until m<2;
  end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку