Электронные часы показывают время в формате h:mm:ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд. Количество минут и секунд при необходимости дополняются до двузначного числа нулями.
С начала суток прошло n секунд. Выведите, что покажут часы.
Входные данные
Вводится целое число n.
Выходные данные
Выведите ответ на задачу, соблюдая требуемый формат.
Примеры
Входные данные
3602
Выходные данные
1:00:02
Входные данные
129700
Выходные данные
12:01:40

#include "iostream"using namespace std;int main(){int secound =0;int hh =0;int mm =0;int ss =0;cin >> secound;int temp = secound;for(int i = 0; i <= secound; i++){if(i == 60){mm++;i-=60;secound-=60;}if(mm == 60){hh++;mm=0;}}ss = temp - hh*3600 - mm *60;cout << hh <<":"<< mm << ":" << ss;return 0;}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку