С++
Электронные часы показывают время в формате h:mm:ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд. Количество минут и секунд при необходимости дополняются до двузначного числа нулями.
С начала суток прошло n секунд. Выведите, что покажут часы.
Входные данные
Вводится целое число n.
Выходные данные
Выведите ответ на задачу, соблюдая требуемый формат.
Примеры
Входные данные
3602
Выходные данные
1:00:02
Входные данные
129700
Выходные данные
12:01:40

//текуще время
#include
#include
#include
using namespace std;

string dig(int n)
{   
   string st="";
   if (n>9) {  st=st+char(n%10+48);  st=char(n/10+48)+st; }
   else  st=st+0+char(n+48);
   return(st);
}

int main(int argc, char** argv) {
   int n,k,m,sc;
   string s="";
   cout<<"n = ";   cin>>n;  cout<   k=n/3600;
   m=(n-k*3600)/60;
   sc=n-k*3600-m*60;
   if (k>24)  k=k%24;
   if (k<10)  s=s+char(k+48)+:;
   else s=s+dig(k)+:;
   s=s+dig(m)+:;
   s=s+dig(sc);
   cout<<"time:  "<   system("pause");
   return(0);
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку