Напишите программу, которая получает натуральные числа A и B (A
На языке C.
#include
#include
#include
bool simpl(int n)
{
int k=0;
for (int i=2; i<=sqrt(n); i++)
if ((n % i)==0) { k=1; break; }
if (k==0) return true;
else return false;
}
int main() {
int a,b;
printf("A = "); scanf("%i",&a);
printf("B = "); scanf("%i",&b);
for (int i=a; i<=b; i++)
if (simpl(i)) printf("%i ",i);
printf("n");
getch();
return(0);
}
Оцени ответ
