На обработку данных поступает натуральное число не превышающее 10000000000.Нужно написать программу,которая находит сумму цифр числа меньших 6,если таких нет,то выводится "нет"
Var
n: longint;
s: integer;
p: boolean;
begin
s:=0;
readln(n);
while n > 0 do
begin
if n mod 10 < 6 then
begin
inc(s, n mod 10);
p:=true;
end;
n := n div 10;
end;
if p = true then
writeln(s)
else
writeln(Нет);
end.
Оцени ответ
