Помогите написать программу.Известно,что x кг конфет - стоит a рублей.Определить сколько стоит y кг этих же конфет,а так же сколько кг конфет можно купить на k рублей.Все значения вводит пользователь

Program konfeta;
uses crt;
var a,b,c,k:integer; 
   d,e,m:real;
begin 
clrscr; 
write(Input (x) weight: ); 
readln(b); 
write(Input (a) cost: ); 
readln(a); 
d:=a/b; 
write(1 kg cost ,d:2:2); 
writeln; 
write(Input (y)kg: ); 
readln(c); 
e:=c*d; 
writeln(c , kg cost= ,e:2:2); 
write(Input k rub: ); 
readln(k); 
m:=k/d; 
writeln(k , rub cost ,m:2:2 , kg.); 
write(Press any key...); 
repeat until 
keypressed;
end.

если надо пояснение пиши

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку