1) Совершенным называется число, равное сумме всех своих делителей, меньших его самого (например, число 6 = 1 + 2 + 3). Напишите программу, которая вводит натуральное число N и определяет, является ли число N совершенным

Function Check(a : Integer) : Boolean;
Var i,s : Integer;
Begin
  s:=0;
  For i:=1 to a-1 do
    If a mod i=0 then s:=s+i;
  Check:=s=a;
end;
Var N : Integer;
Begin
  Readln(N);
  Writeln(Check(N));
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку