Написать программу, которая выводит текстовое описание числа. На вход числа от 100 до 399. На
выходе число текстом. Например, на вход 217 вывод: «двести семнадцать»
Program rtr1;Uses crt;var a,s,d,e:integer; ss,dd,ee:string;beginclrscr;Writeln(Введите число от 100 до 399);readln(a);s:=a div 100;e:=a mod 100 mod 10;d:=a div 10 mod 10;case s of1: ss:=сто;2: ss:=двести;3: ss:=триста;end;case d of2: dd:=двадцать;3: dd:=тридцать;4: dd:=сорок;5: dd:=пятьдесят;6: dd:=шестьдесят;7: dd:=семьдесят;8: dd:=восемьдесят;9: dd:=девяносто;end;case e of1: ee:=один;2: ee:=два;3: ee:=три;4: ee:=четыре;5: ee:=пять;6: ee:=шесть;7: ee:=семь;8: ee:=восемь;9: ee:=девять;end;if d=1 then begin case e of 1: dd:=одинадцать; 2: dd:=двенадцать; 3: dd:=тринадцать; 4: dd:=четырнадцать; 5: dd:=пятнадцать; 6: dd:=шестнадцать; 7: dd:=семнадцать; 8: dd:=восемнадцать; 9: dd:=девятнадцать; end;write(ss, ,dd);end elsewrite(ss, ,dd, ,ee);
end.
