Дано четырехзначное число. Написать программу, которая определяет равна ли сумма первых двух его цифр сумме двух его последних цифр.
var
a,a1,a2,a3,a4:integer;
begin
readln (a);
a1:=a div 1000 ;
a2:=a div 100 mod 10;
a3:=a div 10 mod 10;
a4:=a mod 10;
if (a1+a2) = (a3+a4) then writeln (Равена)
else
writeln (Не равна);
end.
Оцени ответ
