Составить программу в Паскале.Даны три положительных числа а,в,с. Проверить, могут ли быть они длинами сторон треугольник. Если да, то вычислить площадь треугольника. (Нужно учитывать, что стороны не могут равняться нулю. И возможно существование равностороннего треугольника) Основные формулы: а<=б+с, б<а+с, с<=а+б

var a,b,c,p:integer;
begin
  writeln(введите a);
   readln(a);
  writeln(введите b);
   readln(b);
  writeln(введите c);
   readln(c);
  if (a<=b+c) and (b    begin
       p:=(a+b+c) div 2;
       writeln(Треугольник может существовать);
       writeln(Площадь: , sqrt(p* ((p-a)*(p-b))*((p-c))):1:2);  //Формула герона
    end
  else writeln(Не треугольник);
  readln();
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку