Помогите ,пожалуйста , в Pascal
Написать программу, которая преобразует введенное с клавиатуры двухразрядное шестнадцатеричное число в десятичное.
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
var s:=ReadlnString(Введите двухзначное 16-ричное число);
var mH:array[A..F] of integer:=(10,11,12,13,14,15);
if s.Length=1 then s:=0+s;
var c:=s.ToCharArray;
var n:=0;
for var i:=0 to 1 do
case c[i] of
0..9:n:=16*n+StrToInt(c[i]);
A..F:n:=16*n+mH[c[i]];
else begin
Writeln(Недопустимый символ: ,c[i]);
Exit
end
end;
Writeln(Десятичный эквивалент: ,n)
end.
Тестовое решение:
Введите двухзначное 16-ричное число 3A
Десятичный эквивалент: 58
Оцени ответ
