Дан массив A[8] заполненный целыми числами от 0 до 40 .Найти сумму элементов массива не превышающих 25.
Помогите составить программу в Poskal.Заранее спасибо
Пожалуй надо помочь, хоть название языка программирования узнали.
const n = 8;
var a:array[1..n] of integer;
s,i:integer;
begin
//Заполнение массива значениями в диапазоне
//от 0 до 40
//и одновременно находим нужную сумму
s:=0;
for i:=1 to n do begin
a[i]:=random(41);
if a[i]<=25 then s:=s+a[i];
write(a[i]:3);
end;
writeln;
writeln(Сумма элементов <=25 равна , s);
end.
Оцени ответ
