Пк запрашивает название и радиусы орбит двух планет (в миллионах км) и скорости движения орбит (в миллионах км в сутки). Вычислить продолжительность года на планетах (длина орбит/скорость). Результаты должны иметь вид:

Продолжительность года на планете <имя1> суток;

Продолжительность года на планете <имя2> суток;

Помогите составить программу в Pascal.

Program Planet;

var
R1, R2, l1, l2, v1, v2, time1, time2 : real;
c, b : string;

begin
Write(Планета1-);
Readln(b);
Write(Планета2-);
Readln(c);
Write(R1=);
Readln(R1);
Write(R2=);
Readln(R2);
Write(v1=);
Readln(v1);
Write(v2=);
Readln(v2);
L1:=2*Pi*R1;
L2:=2*Pi*R2;
Time1:=l1/v1;
Time2:=l2/v2;
Writeln(Продолжительность года на пленете ,b,= , Time1:0:2, суток);
Writeln(Продолжительность года на пленете ,c,= , Time2:0:2, суток);
end.

 

 

 

 

как-то так)

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку