Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — максимальное число, кратное 4.
Не знаю, какой язык тебе нужен, но вот фрагмент на VB Console, он, наверное , должен быть понятен всем
dim a,k,n as integer
N = console.readline
For i as integer = 1 to N
a = console.readline
if a mod 4 = 0 and a > k then k = a
Next
Console.WriteLine(a)
Оцени ответ
