Напишите программу в паскале, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4. Количество чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число — максимальное число, кратное 4.
Program zadacha;
var n, x, i, max: integer;
begin
max:=0;
Writeln (Введите количество чисел);
Readln (n);
for i:=1 to n do begin
readln (x);
if (x mod 4=0) and (x>max) then max:=x;
end;
writeln (max)
end.
Оцени ответ
