Написать программу которая получает два целых числа и находит их произведение не используя операцию умножения учтите что числа могут быть
отриц

// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
  var a,b:integer;
  Write(Введите два целых числа: ); Read(a,b);
  if (a=0) or (b=0) then Writeln(Произведение равно нулю)
  else begin
    var s:=1;
    if sign(a)<>sign(b) then s:=-1;
    a:=abs(a);
    var p:=0;
    for var i:=1 to abs(b) do p+=a;
    if s=1 then Writeln(Произведение равно ,p)
    else Writeln(Произведение равно ,-p)
    end
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку