Написать программу которая получает два целых числа и находит их произведение не используя операцию умножения учтите что числа могут быть
отрицательными. (надо в c++)

#include


int main(){
int a, b, i, c = 0, check = 0;

std::cout << "Введите певое значение:";
std::cin >> a;

std::cout << "Введите второе значение:";
std::cin >> b;

if(a < 0){
a*=-1;
check = 1;}

for(i = 0; i < a; i++)
if(check = 0)
c += b;
else
c -= b;
std::cout << c << " ";
std::cin >> b;

return 0;}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку