Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введен нуль) и подсчет суммы и среднего арифметического введенных положительных чисел. Используйте оператор repeat.

Задание на обработку последовательности чисел. Так как есть условие окончания ввода, то имеет смысл использовать цикл repeat ... until

//Pascal
var a,i,s,n:integer;
begin
  s:=0;
  n:=0;
  repeat
     readln(a);
     if a>0 then begin
        n:=n+1;
        s:=s+a;
     end;
  until a = 0;
  writeln(Сумма ,s:5,  Среднее арифметическое ,s/n);
end.

    

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку