Составьте программу в Паскаль, вводящую true, если высказывание является истинным, и false в противном случае.
а) Сумма цифр трёхзначного числа х является чётным числом.
б) Треугольник со сторонами a, b, с являются разносторонним.

1.
Var
  a:integer;
Begin
  Write(Введите число );
  Readln(a);
  if (((a mod 10) + (a div 10 mod 10) + (a div 100)) mod 2) = 0 then write(True) else write(False);
End.
2.
Var
  a,b,c:integer;
Begin
  Write(Введите стороны треугольника );
  Readln(a,b,c);
  if (a=b) or (a=c) or (b=c) then write(False) else write(True);
End.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку