Пожалуйста помогите)Напишите программу, которая определяет, верно ли, что введённое число содержит по крайней мере две одинаковых цифры, возможно, не стоящие рядом
Var
s: string;
i, j, n: integer;
c: char;
flag: boolean;
begin
Write(Введите число: ); Readln(s);
flag := false;
n := length(s);
i := 1;
while (i <= n) and (not flag) do
begin
c := s[i];
j := i + 1;
while (j <= n) and (not flag) do
if s[j] = c then flag := true else j := j + 1;
if (not flag) then i := i + 1
end;
if flag then Writeln(Символ ", c, " встречается больше одного раза)
else Writeln(Все символы разные)
end.
Оцени ответ
