Напишите программу, которая в последовательности целых чисел определяет минимальное ОТРИЦАТЕЛЬНОЕ число, кратное 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется ОТРИЦАТЕЛЬНОЕ число, кратное 6. плиззз дам мноого балов

// Pascal
var n, i, a, min:integer;
begin
min:=666666;
readln(n); //ввод количества чисел
// раз мы знаем количество чисел, то используем цикл for
for i:=1 to n do begin
  readln(a);
  //проверка введенного числа на кратность 6, отрицательность и минимальность
  if (a<0)and (a mod 6 =0) and (a  end;
writeln(min); //вывод минимального отрицательного кратного 6
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку