Составьте программу которая по трем введенным вами числам определит могут ли эти числа быть длинами сторон треугольника и если да то определить вид этого треугольника
Var
a, b, c: real;
begin
writeln(Введите два катета A,B и гипотенузу С треугольника);
readln(a, b, c);
if (c >= a + b) or (a + b + c = 0) then writeln(Такого треугольника не существует)
else begin
if sqr(c) = sqr(a) + sqr(b) then writeln(Прямоугольный);
if sqr(c) > sqr(a) + sqr(b) then writeln(Тупоугольный);
if sqr(c) < sqr(a) + sqr(b) then writeln(Остроугольный);
end;
end.
Оцени ответ
