Напишите программу, которая считывает с клавиатуры последовательность символов и выводит на экран:
а)количество считанных десятичных цифр;
б)количество четных цифр;
в)количество нечетных цифр;

Program qq;
cons N=(количество чисел которые вы вводите)
var i, k1, k2, k3:integer;
 A:array[1..N] of longint;
begin
for i:=1 to N do readln(A[i]);
k1:=0; k2:=0; k3:=0;
 for i:=1 to N do 
  if (A[i]>=0) and (A[i]<10) then k1:=k1+1; (десятичные цифры)
 for i:=1 to N do
  if (A[i]mod2=0) then k2:=k2+1 (четные)
    else k3:=k3+1; (нечетные)
writeln(k1, k2, k3);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку