Помогите! Дана последовательность чисел, которая оканчивается на 0. Найдите наименьшее число, которое оканчивается на 5.
заранее спасибо)
очень надо, сразу говорю)
программа: Pascal ABC . net
1.Как я понял, последовательность вводится с клавиатуры и признак окончания ввода - 0. Значит имеет смысл использовать цикл Repeat
2. Вводимые числа - целые.
После этих уточнений можно написать код на PascalABC:
//Вариант с циклом repeat
var
a, min: integer;
begin
min := 555555;
repeat
readln(a);
if ((a mod 10 = 5) or (a mod 10 = -5)) and (a < min) then
min := a;
until a = 0;
writeln(min);
end.
//вариант с циклом while
var
a, min: integer;
begin
min := 555555;
readln(a);
while (a>0) or (a<0) do begin
if ((a mod 10 = 5) or (a mod 10 = -5)) and (a < min) then
min := a;
readln(a);
end;
writeln(min);
end.
Оцени ответ