. Составить программу для нахождения и печати всех Пифагоровых чисел, не превышающих 20.

Пифагоровыми числами называются числа, для которых выполняется равенство a²+b²= c².

//Pascal
var
  i, j, k: integer;

begin
  for i := 1 to 20 do
    for j := i to 20 do
      for k := j to 20 do if i * i + j * j = k * k then writeln(i:4, j:4, k:4);
 
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку