Написать программу:
Вычислить количество точек с целочисленными координатами, попадающих в круг с радиусом r и с центром в начале координаты
Ур: x*x+y*y= r*r

Var i,j,n,k: integer;    r: real;begin  write(радиус:  );  readln(r);  n:=trunc(r);  k:=0;  for i:=-n to n do  for j:=-n to n do  if sqr(i)+sqr(j)<=sqr(r) then k:=k+1;  writeln(число точек в круге:  ,k);end.    

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку