Помогите с задачей на языке питон 3 :Последовательность состоит из натуральных чисел и завершается числом 0. Определите значение наибольшего элемента последовательности.

В Python нет цикла похожего на Repeat ... Until в Pascal. Поэтому обойдемся циклом while:

a = int(input())
max =a
while a!=0:
    a = int(input(a))
    if a > max:
      max = a
print (max)


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку