Паскаль
Даны натуральные числа n и k. Написать программу вычисления выражения
1^k+2^k+3^k+4^k+…+n^k
// PascalABC.NET 3.1, сборка 1190 от 05.03.2016
begin
var n:=ReadInteger(n=);
var k:=ReadInteger(k=);
var s:=Biginteger(0);
for var i:=2 to n do s+=Power(Biginteger(i),k);
Writeln(Сумма ,s+1)
end.
Тестовые решения:
n= 10
k= 30
Сумма 1043651859661187698792930519525
n= 5
k= 2
Сумма 55
n= 38
k= 67
Сумма 8400313720757760689953535296227476513296331784292134843927352320607786766609162308796108536127867158913721
Оцени ответ
