Написать программу тест состоящую из пяти произвольных вопросов выдающую результат
Program test; var a:array [1..20] of string; b,c,d,e,f:string; i:byte; begin writeln(Ответами в тесте будут являться номера ответов, а не сами ответы.); writeln(Отмена крепостного права:); a[1]:=(1. 1861 г.); a[2]:=(2. 1886 г.); a[3]:=(3. 1855 г.); a[4]:=(4. 1889 г.); for i:=1 to 4 do begin writeln(a[i]); end; readln(b); if b=1 then writeln(Ответ верный) else writeln(Ответ неверен); //------------------------------------------------------------------- writeln(Сколько будет корень третий степени из 8:); a[5]:=(1. 8); a[6]:=(2. 4); a[7]:=(3. 1); a[8]:=(4. 2); for i:=5 to 8 do begin writeln(a[i]); end; readln(c); if c=4 then writeln(Ответ верный) else writeln(Ответ неверен); //------------------------------------------------------------------- writeln(Сколько слогов в слове рыбак:); a[9]:=(1. 3); a[10]:=(2. 4); a[11]:=(3. 2); a[12]:=(4. 1); for i:=9 to 12 do begin writeln(a[i]); end; readln(d); if d=3 then writeln(Ответ верный) else writeln(Ответ неверен); //------------------------------------------------------------------- writeln(Столица Португалии:); a[13]:=(1. Париж); a[14]:=(2. Лондон); a[15]:=(3. Лиссабон); a[16]:=(4. Оренбург); for i:=13 to 16 do begin writeln(a[i]); end; readln(e); if e=3 then writeln(Ответ верный) else writeln(Ответ неверен); //------------------------------------------------------------------- writeln(Как с английского переводится слово circuit:); a[17]:=(1. Лампа); a[18]:=(2. Колонка); a[19]:=(3. Электрон); a[20]:=(4. Схема); for i:=17 to 20 do begin writeln(a[i]); end; readln(f); if f=4 then writeln(Ответ верный) else writeln(Ответ неверен); end.
У меня в паскале компилируется, всё работает. Если криво, ниже картинка
