Напишите программу, которая считает сумму цифр введённого числа.
Язык Python. Спасибо,кто поможет

Ну я бы на Питоне сделал бы это так:

n = input()
s = 0
for i in n:
    s += int(i)
print("Сумма цифр:", s)

Небольшая хитрость. На входе получаем не число, а строку. А дальше каждый символ строки переводим в цифру и суммируем.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку