Дана непустая последовательность символов. Требуется построить и напечатать множество, элементами которого являются встречающиеся в последовательности:
3.1. Знаки операций отношения;
3.2. Вычислить количество элементов в созданных множествах
написать программу на языке паскаль

// PascalABC.NET 3.1, сборка 1192 от 07.03.2016
begin
  var s:=My chars: 3.5<7, 2>4, 2*48;
  Print(Исходная последовательность:); s.Println(,);
  Write(Найдены операции отношения: );
  var hs:=s.Where(c->Pos(c,<>=)>0).ToHashSet;
  hs.Println(,);
  Writeln(Мощность множества равна ,hs.Count)
end.

Тестовое решение:
Исходная последовательность: M,y, ,c,h,a,r,s,:, ,3,.,5,<,7,,, ,2,>,4,,, ,2,*,4,8
Найдены операции отношения: <,>
Мощность множества равна 2

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×