Имеется стопка квадратных плиток разных размеров. Сторона квадрата - случайное целое число из диапазона от 0 до 6 (использовать функцию random). Написать программу, которая вычисляет площадь каждого квадрата. Программа заканчивается, если сторона квадрата равна 0. Использовать функцию (While условие Do оператор "Условный цикл с предусловием") Написать программу в Pascal.

// PascalABC.NET 3.1, сборка 1198 от 11.03.2016
var
  a:integer;
begin
  Randomize;
  a:=Random(7);
  while a>0 do begin
    Writeln(a=,a,, s=,a*a);
    a:=Random(7)
    end
end.

Тестовое решение:
a=5, s=25
a=1, s=1
a=6, s=36
a=4, s=16
a=3, s=9

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку