Номер билета в трамвае состоит из 6 цифр. Счастливым называется билет, сумма первых трех цифр в котором равна сумме последних трех.
Сколько существует счастливых билетов таких, что они состоят только из цифр от 2 до 9 (при этом могут использоваться не все цифры)?
Число билетов: 18152
var i,j,k,nmb: integer; a: array[6..27] of integer;begin for i:=2 to 9 do for j:=2 to 9 do for k:=2 to 9 do inc(a[i+j+k]); { подсчет числа билетов} nmb:=0; for i:=6 to 27 do nmb:=nmb+a[i]*a[i]; writeln(число билетов: ,nmb);end.
Оцени ответ
