For k:=1 to n do
Напишите программу, которая в последовательности натуральных чисел определяет максимальное четное число.
Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется чётное число. Количество чисел не превышает 1000. Введенные числа не превышают 30000.
Программа должна вывести одно число - максимально чётное число.

Program p12;
type tab=array[1..1000] of 1..30000;
var t:tab;
i,max,n:integer;
begin
readln(n);
for i:=1 to n do
readln(t[i]);
for i:=1 to n do
if(t[i] mod 2=0) and (t[i]>max) then max:=t[i];
write(max);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку