РЕЬЯТ ПОМОГИТЕ СРОЧНООО
Напишите программу вычисления выражения: s=1!+2!+3!+...+n!
Используйте функцию вычисления факториала
Var n,i,s:integer;
function fact(k:integer):integer;
var j,f:integer;
begin
f:=1;
for j:=1 to k do f:=f*j;
fact:=f;
end;
begin
write(n=); readln(n);
s:=0;
for i:=1 to n do s:=s+fact(i);
writeln(s=,s);
end.
Пример:
n=5
s=153
Оцени ответ
