По данному числу N распечатайте все целые степени двойки, не превосходящие N, в порядке возрастания.
Операцией возведения в степень пользоваться нельзя!
Входные данные
Вводится натуральное число.
Выходные данные
Выведите ответ на задачу.
Примеры
входные данные
50
выходные данные
1 2 4 8 16 32

Var n,k:integer;
begin
write(n=); readln(n);
k:=1;
while k<=n do
 begin
 write(k,  );
 k:=k*2;
 end;
writeln;
end.

Пример:
n=50
1  2  4  8  16  32

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку