Дана программа, написанная на языке Pascal, формирующая квадратный массив и заполняющая его по определённым правилам. Чему будет равно значение переменной Р по окончании выполнения программы?
const N=7;
var i, К:integer;
R, P:real;
A:array[1..N,1..N] of real;
beginK:=0; R:=0;

while K

begin

for i:=1 to N-K do

begin

R:=R+1;

A[i,i+K]:= R;

end;

K:= K+1;

end;

P:= A[3,7];

writeln(P);

end.

А) 17 Б) 22 В) 25 Г) 28

1. После первого begin добавьте перевод строки. Иначе программа работать не будет.
2. Результат P = 25

Ответ: вариант В

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку