Ниже записан алгоритм. Получив на вход число x, этот алгоритм печатает число M. Известно, что x > 100. Укажите наименьшее такое (т.е. большее 100) число x, при вводе которого алгоритм печатает 2.
Очень подробное решение пожалуйста
var x, L, M: integer;
begin
readln(x);
L := x - 12;
M := x + 12;
while L <> M do
if L > M then
L := L - M
else
M := M – L;
writeln(M);
end.
Очень подробное решение пожалуйста

106

function f(x: integer): integer;
var
    L, M: integer;
begin
    L := x - 12;
    M := x + 12;
    while L <> M do
        if L > M then
            L := L - M
        else
            M := M - L;
    f := L;
end;

begin
    var x := 100;
    var r := 0;
    repeat
        x := x + 1;
        r := f(x);
    until r = 2;
    writeln(x);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку