Написать программу в на языке Pascal. По желанию помочь понять, что в моем коде не так: var a, b, c, s, k, y:real;
begin
writeln(Введите числа a,b,c);
readln(a, b, c);
s :=(sqrt(a + b*b*b*b*b))/(3 * c);
k :=s - (sqrt(abs(a * b * c)));
y :=(s + k) - (s/(b*c));
writeln(y= ,y);
end.
(человека, который поможет отмечу лучшим)
При таком наборе данных при вычислении значения s получается корень квадратный из отрицательного числа -29. Поэтому программа и выдает сообщение : Не число.
Набор данных некорректен.
Оцени ответ
