1.Вычислите сумму элементов массива. Элементы массива вводятся с клавиатуры. Составить алгоритм решения задачи и написать программный код на языке Паскаль.
2. Составьте алгоритм и программу нахождения полупроизведения двух чисел. Составить алгоритм решения задачи и написать программный код на языке Паскаль.
3.Составьте программу,реализующую эпизод применения компьютера в книжном магазине. Компьютер запрашивает стоимость книг,сумму денег,внесённую покупателем. Если здачи не требуется,печатает на экране"Спасибо";если денег внесено больше,то печатает "Возьмите сдачу" и сумму сдачи;если денег недостаточно ,то печатает об этом сообщение и указывает размер недостающей суммы. Составить алгоритм решения задачи и написать программный код на языке Паскаль.
1.
program z_1;
var i,s;intger;
a:array [1..50] of integer;
begin
for i:=1 to 50 do
begin
readln(a[i]);
s:=s+a[i];
end;
writeln(s);
end.
2.
program z_2;
var c1,c2,pp:integer;
begin
readln(c1);
readln(c2);
pp:=round((c1*c2)/2);//полупроизведение двух чисел
writeln(pp);
end.
3.
program z_3;
var k,v,s:integer;
begin
readln(k);//Стоимость книги
readln(v);//Внесено денег
if k=v then
writeln(Спасибо!)
else
if k
else
writeln(Недостаточно средств : ,k-v);
end.
Оцени ответ
