Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — сумму чисел, оканчивающихся на 4.
Помогите пожалуйста вообще не понимаю(( заранее спасибо
//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var a,n,s,i:integer;
begin
readln(n); //ввод количества членов последовательности
for i:=1 to n do begin
readln(a); //ввод очередного числа
if a mod 10 = 4 then s:=s+a; //число оканчивается 4
end;
writeln (s); //Вывод суммы оканчивающихся на 4
end.
Оцени ответ