
Напишите программу на языке программирования (или составьте алгоритм). Вычислить значение функции у = х^3+12 для х ϵ [–2, 2] при шаге изменения аргумента 0.2. Выполнить программу и получить результат.

// PascalABC.NET 3.1, сборка 1200 от 13.03.2016
begin
var x:=-2.0;
while x<=2 do begin
Writeln(x=,x:4:1, y=,x*x*x+12:6:3);
x+=0.2
end
end.
Результат выполнения программы:
x=-2.0 y= 4.000
x=-1.8 y= 6.168
x=-1.6 y= 7.904
x=-1.4 y= 9.256
x=-1.2 y=10.272
x=-1.0 y=11.000
x=-0.8 y=11.488
x=-0.6 y=11.784
x=-0.4 y=11.936
x=-0.2 y=11.992
x= 0.0 y=12.000
x= 0.2 y=12.008
x= 0.4 y=12.064
x= 0.6 y=12.216
x= 0.8 y=12.512
x= 1.0 y=13.000
x= 1.2 y=13.728
x= 1.4 y=14.744
x= 1.6 y=16.096
x= 1.8 y=17.832
x= 2.0 y=20.000
Оцени ответ